算法竞赛--vector的使用

1.vector的定义

1
vector<typename> name;

2.vector的遍历

1
2
3
vector<int> v;
for(vector<int>::iterator it=v[num].begin();it!=v[num].end();it++)
printf(" %d",*it);

3.常用函数

1.在vector后面添加一个元素 push_back()

1
2
3
vector<int> v;
for(int i=0;i<10;i++)
v.push_back(i);

2.在vector后面删除一个元素 pop_back()

1
2
3
vector<int> v;
for(int i=0;i<10;i++)
v.pop_back();

3.求vector的长度

1
2
vector<int> v;
v.size();

4.清空vector中所有元素

1
2
vector<int> v;
v.clear();

5.向vector中任意迭代器it处插入一个元素x

1
2
vector<int> v;
v.insert(v.begin(),-1); //向v[0]处插入-1

6.删除单个元素

1
2
vector<int> v;
v.erase(v.begin()); //删除元素v[0]

7.删除一个区间内所有元素 注意左闭右开

1
2
vector<int> v;
v.erase(v.begin(),v.end()); //删除所有元素

1.Course List for Student

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入信息:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出信息:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

样例输入:

1
2
3
4
5
6
7
8
9
10
11
12
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出:

1
2
3
4
5
6
7
8
9
10
11
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

思路:利用 vector和哈希解题

代码如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
#include <bits/stdc++.h>
const int Max=26*26*26*10+5;
using namespace std;
int Hash(char str[]) //进行哈希定位
{
int num=0;
for(int i=0;i<3;i++)
num=num*26+(str[i]-'A');
num=num*10+(str[3]-'0');
return num;
}
vector<int> v[Max];
int main()
{
int n,m;
scanf("%d%d",&n,&m);
for(int i=0;i<m;i++)
{
int c,s;
scanf("%d%d",&c,&s);
for(int j=0;j<s;j++)
{
char str[10]={0};
scanf("%s",str);
int num=Hash(str);
v[num].push_back(c);//将课程号存入到对应学生数组中
}
}
for(int k=0;k<n;k++)
{
char str[5];
scanf("%4s",str);
int num=Hash(str);
printf("%s %d",str,v[num].size());
sort(v[num].begin(),v[num].end()); //对课程号进行排序否则WA50%
for(vector<int>::iterator it=v[num].begin();it!=v[num].end();it++)
printf(" %d",*it);
printf("\n");
}
return 0;
}
小礼物走一个哟
0%